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1	 Edit View
1.1	 DRAWING PATHS

1.1.1	 Freehand Outlines
Create paths with the Draw or Primitives tools. When the 
Draw tool  (shortcut P) is active, click to create straight 
lines, or click and drag to create curves. Move the curve point 
by holding down the space bar. Close the outline by clicking 
on its first node.
	 Nodes in smooth connections will appear as green circles. 
A smooth connection can either be a curve (an on-curve 
point in line with two surrounding off-curve points) or a 
tangent (an on-curve point in line with another on-curve 
point and an off-curve point).
	 In order to draw a corner, hold down the Option key while 
dragging. Corner points are marked by blue circles. Points in a 
corner connection are not kept in line, so you can move them 
independently from each other.
	 Handles (Bézier control points, off-curve points) control 
the curvature of the path segment and are displayed as 
grey circles.

1.1.2	 Primitives
Glyphs offers rectangles and ovals as built-in primitive 
shapes. Click and hold the Primitives tool to choose between 
the two shape options.

	

Click once on the canvas to create a primitive by entering its 
measurements with the keyboard. Or click and drag to draw 
it directly into the Edit area. Hold down shift for a perfect 
square or circle.
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1.2	 EDITING PATHS

1.2.1	 Select Tool
Click and drag with the Select tool  (shortcut V) to select 
nodes and handles inside a rectangle. Hold down the Shift 
key to extend or reduce the selection. Note that, unlike 
most editors, Glyphs allows you to select multiple handles 
independently of the nodes.
	 Move the selection using the mouse or the cursor keys. 
This also works if more than one handle is selected. Moving 
nodes will move the attached handles even if they are not 
selected. Hold down the Option key to move only explicitly 
selected points. When moving a handle while holding down 
the Option key, its angle will be preserved. Convert between 
smooth connection and corners by double clicking or 
selecting the node and pressing Return.
	 Option-clicking a line segment converts it into a curve 
segment, i.e. adds handles. To convert a curve back into a line 
segment, select and delete one or both handles.

1.2.2	 Scaling and Rotating
The attributes of the selection are shown in the grey info box 
(View > Show Info):

	

When more than one node is selected, you can scale or move 
the selection by changing the numbers for its position (x and 
y) and its dimensions (w for width, h for height) in the info 
box. Set the transformation origin with the nine reference 
points on the left. Close the lock symbol to scale width and 
height proportionally. Open the lock to distort the selection, 
i.e. scale width and height independently from each other.
	 You can also rotate and scale your selection with the 
Rotate tool   (shortcut R) and the Scale tool   (shortcut S). 
Click to set the transformation origin, click and drag to rotate 
or scale, respectively. Hold down the Shift key to rotate in 
steps of ninety degrees and scale proportionally.
	 More path transformations are possible via the Palette. See 
the Palette chapter for further details.

Tip: Quickly add handles 
by Option-clicking on the 

outline between two nodes. 

Tip: In all number input fields 
throughout the application, you 
can use the up and down cursor 

keys to increase or decrease 
the value. Simultaneously 

holding down the Shift key 
gives you increments of 10.
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1.2.3	 Deleting Nodes
Simply select a node and hit the Delete key to delete the node. 
Alternatively, you can use the Erase tool  (shortcut E). 
Glyphs will keep the path closed and try to reconstruct the 
path segment without the node:

	

Hold down the Option key to break the path, i.e. remove the 
node and both path segments surrounding the node.

1.2.4	 Opening and Closing Paths
With the Draw tool , click on a node to open the path in 
the position of the node. Open path endings are marked by 
perpendicular blue lines. You can now drag them apart with 
the Select tool .

	

To close the path again, simply drag the open line endings 
onto each other using the Select tool.

1.2.5	 Cutting Paths
With the Knife tool  (shortcut E), click and drag a line 
across a path, to cut the outline into two separate outlines. 
Glyphs will close the two resulting paths along the 
cutting line.

	

Tip: A quick way to get rid 
of a path segment between 

two nodes is to insert 
a point with the Draw 

tool (P) and immediately 
Option-delete it.
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To activate the Knife tool, click and hold the Erase tool. 
Choose Knife from the pop-up menu.

	

1.2.6	 Resegmenting Outlines
In order to segment a closed path, select two nodes and select 
Reconnect Nodes from the context menu. To open the context 
menu, right-click or Ctrl-click. If only one node is selected, 
the Open Corner command becomes available instead. It 
works in a similar fashion. Resegmenting your outlines this 
way allows to edit the path segments independently from 
each other. It also makes interpolating easier.

	

1.2.7	 Controlling Path Direction
The starting point of a path is displayed as a triangle, 
indicating the path direction. Again, green and blue denote a 
smooth connection or a corner, respectively. You can make 
any on-curve node the first node by selecting it and picking 
Make Node First from the context menu.
	 All outer paths need to run counter-clockwise, while 
counters must be turned clockwise. You can change a path’s 
direction by selecting it and choosing Reverse Selected 
Contours from the context menu. Use the Reverse Contours 

Tip: a quick way to get 
your counters right is to 

draw both inner and outer 
shapes, and hit Cmd-Shift-R 

(Correct Path Direction). 
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from the Layer menu to switch all paths in a glyph. If you 
pick the Correct Path Direction command from the same 
menu, Glyphs performs an informed guess and finds the right 
path orientation for all contours in the selected glyphs. This 
will also rearrange the contour order and reset the starting 
points of all paths to the top right nodes.

	

For interpolation, path order, starting points and path 
directions need to be compatible and consistent throughout 
all font masters.

1.3	 GUIDELINES

1.3.1	 Magnetic Guidelines
If you drag nodes across the canvas, red lines will appear, 
indicating when you are aligned with other nodes or a 
vertical metric.

1.3.2	 Local and Global Guidelines
To add a guideline, right- or Ctrl-click to open the context 
menu and choose Add Guideline. A horizontal blue line 
appears. You can activate it by clicking the little circle on it, 
alter its position by clicking and dragging the circle. Double 
click it to turn it perpendicular to its original orientation. 
Click and drag a guideline close to its circle to rotate it.
	 To turn it into a global guideline, i.e. a guideline that 
appears in all glyphs throughout the master, right- or Ctrl-
click the circle and choose Make Global Guideline from the 
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context menu. The guideline will turn red. To make it local 
again, cut and paste it. Pasted guidelines will always be local.

	

When a guideline is selected, you can also enter values for 
its position and its angle in the grey info box. By default, a 
guideline will be set relative to the left sidebearing. However, 
if you change the alignment of the guideline by clicking 
on the Alignment icon in the info box, the guideline will 
stay fixed relative to the right sidebearing. This is useful 
for slanted guidelines if they are global or when the right 
sidebearing is changed.
	 With the Measurement checkbox, you can turn it into a 
measurement guideline. For more details on measurement 
guidelines, see the Measuring section in this chapter.

1.4	 GLYPH DISPLAY

1.4.1	 Zooming
There are many ways to zoom in and out in Edit View. If 
you are on a MacBook or have a trackpad to your disposal, 
you can use pinch and stretch gestures. Or hold down the 
Option key and use a scroll gesture or the scroll wheel of your 
mouse. Or activate the Zoom tool  (shortcut Z) and click in 
the canvas to zoom in, Opt-click to zoom out, click and drag 
across an area that will be zoomed to fill the window.
	 Or you can use the zoom commands from the View menu: 
Zoom In (Cmd-plus) and Zoom Out (Cmd-dash). Zoom to 
Active Layer (Cmd-zero) will maximize the area between 
ascender and descender in the window. Zoom to Actual Size 
(Cmd-Opt-zero) will zoom one unit to the size of one pixel on 
the screen.

	

Or you can use the zoom buttons in the bottom right corner 
of the window. Alternatively, you can set the zoom value 
numerically by entering a point height in the field between 
the buttons. The value specifies at which size 1000 units will 
be displayed. Since Mac OS X assumes a screen resolution of 
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72 ppi, one point corresponds to one actual screen pixel, so if 
you enter a value of 1000, one unit will zoom to one pixel.

1.4.2	 Panning
You can use trackpad panning gestures. Use the wheel of 
your mouse to scroll vertically, hold down shift to scroll 
horizontally.
	 Alternatively, you can switch to the Hand tool  
(shortcut H) and drag the canvas around. As long as you 
are not in text mode, you can hold down the space bar to 
temporarily switch to the Hand tool.

1.4.3	 Nodes in Alignment Zones

	

Nodes located exactly on a vertical metric line (see the 
Font Info chapter for further details) are highlighted with 
a beige diamond. Inside an alignment zone (see Font Info), 
the highlighting assumes the shape of a circle. This helps 
controlling the position of nodes even at small zoom scales.

1.4.4	 Anchors and Clouds
Letters built from components, so-called compound glyphs, 
are handled in a special way. Accented or marked letters, 
built from a base letter and a mark, automatically inherit 
the spacing from the base glyph. The mark is positioned 
according to the anchor positions. The accented letters are 
always in sync with the base letter, even if spacing or anchor 
positions are changed.
	 Anchors are added to most glyphs automatically with the 
Set Anchors command from the Layers menu (Cmd-U). If you 
hold down the Option key, Glyphs will delete all anchors in 
the selected letters and reset the built-in standard anchors.
	 Once you have anchors in your letters, all you need to 
do is to refine their position. An anchor in the base glyph 
is connected with the anchor in the mark glyph by sharing 
the same name and additional underscore prefix, e.g. a ‘top’ 

Pro User Tip: If you want 
to control which marks 

are associated with which 
base glyph, create a copy of 

GlyphsData.xml in ~/Library/
Application Support/Glyphs/

Info/ and edit the anchors 
and accents attributes. You 
will find the XML file in the 

Package Contents of the 
Glyphs application. Drill down 

to Contents/Frameworks/
GlyphsCore.framework/

Versions/A/Resources.
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anchor in the base glyph and a ‘_top’ anchor in the mark are 
used to place the mark glyph in the compound glyphs.
	 Select an anchor in the base glyph to get a preview of 
the most common accents that may attach to this glyph. 
Similarly, select an anchor in the mark glyph and this accent 
is shown on all other glyphs in the same edit view.
	 Sometimes you need more than one ‘top’ anchor. This 
is the case for Arabic ligatures and Vietnamese letters. In 
this case, add an underscore and a number or a suffix to the 
anchor name, e.g. ‘top_viet’ or ‘top_1’, ‘top_2’ and so on. Then, 
in the compound glyph, select the mark, and via the anchor 
symbol in the grey Info panel, select to which anchor the 
mark component should attach. The anchor symbol becomes 
visible if there is more than one anchor that fits.

	

When building letters from several base glyphs, the 
components are set next to each other using the spacing and 
kerning for this combination. For example when building a 
fraction out of one.numr, fraction and two.dnom, the fraction 
will look as if the letters were typed individually.

1.5	 BACKGROUND
The background layer is useful for storing a path temporarily. 
Filters may use the background as backup layer in order to 
work non-destructively. To activate the background, choose 
Edit Background from the Layers menu (Cmd-B). The window 
display will darken slightly to indicate that you are in the 
background layer.
	 Layers > Selection to Background (Cmd-K) replaces the 
current content of the background with the active selection; 
this works in reverse when the background is active. 
Simultaneously holding down the Option key (or pressing 
Cmd-Opt-K) adds the current selection to the background 
without clearing it first.
	 Via Layer > Assign Background, you can put another font in 
the background layer of all selected glyphs.
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1.6	 ENTERING TEXT
The Edit View also acts as a simple text editor, and as such 
allows you to edit your glyphs in the context of a whole word 
or even sentence.
	 The Edit View is limited to a certain width. You can set 
the maximum width in the application preferences. Select 
Glyphs > Preferences, switch to User Preferences and edit the 
Text View Width value accordingly.

 

1.6.1	 Sample Texts
You can edit and store any number of sample texts in the 
application preferences. Select Glyphs > Preferences and then 
switch to the Sample Text tab. You can also enter individual 
glyph names if you escape them with a leading slash and a 
trailing space, e.g. ‘H/adieresis mmer’ will result in ‘Hämmer’.
	 To make an Edit tab display any of these texts, choose 
Edit > Select Sample Text (Cmd-Opt-F). In the appearing dialog, 
use your arrow keys or click on a line to pick the sample text 
and hit Return or click the OK button afterwards.
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1.6.2	 Text Tool
Select the Text tool (shortcut T) to switch to text mode 
and start typing. You can enter multiple words, complete 
sentences, even line breaks. You can copy and paste text into 
and from the Edit tab. The arrow keys, the Edit commands 
and OS X Application Services work as they would in any 
Mac app.
	 Edit > Add Placeholder (Cmd-Opt-Shift-P) inserts 
a placeholder for the current glyph. Placeholders are 
dynamically replaced by the currently selected glyph.
	 To insert a glyph that you cannot or do not know how 
to type with the keyboard, choose Find from the Edit > Find 
submenu (Cmd-F). In the dialog that appears, enter the name 
or a part of the name of the glyph. The dialog will show a list 
of glyphs whose name contains the text you entered. Select 
the glyph you want and hit Return or click the Select button 
to insert it into your sample text.

1.7	 MEASURING
Glyphs offers several ways to determine coordinates and 
measure distances between points and curves.

1.7.1	 Info Box
The grey info box (View > Show Info) always displays info 
relevant to the current selection. If there is exactly one node 
selected, its coordinates will be displayed.

	

Select a handle (off-curve point, Bézier control point), and the 
info box will also carry its delta values (x and y difference 
to the on-curve point) and the total length of the handle 
(distance to the on-curve point).

	

If you select more than one point, be it on- or off-curve 
points, the info box will display the width and the height of 
the box defined by the current selection. To measure a stem or 
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bowl width, select two nodes that indicate the width and see 
what the info box displays next to ‘w:’.

	

1.7.2	 Measurement Tool
Switching to the Measurement Tool  (shortcut L) allows you 
to see all coordinates at once.

	

The blue numbers are the x and y coordinates of the on-
curve points, the red numbers are the x and y delta values 
between the on-curve points. These values help you check 
the symmetry of your curves.
	 Clicking and dragging draws a ruler that displays precise 
measures between all of its intersections with outlines. At the 
end of the ruler, its angle is displayed.

	

You can always temporarily activate the ruler by 
simultaneously holding down Ctrl, Option and Command.

1.7.3	 Measurement Guidelines
Any guideline, even a global guideline, can be turned into 
a measurement guideline. Simply select the guideline by 
clicking on its selection handle and activate the Measurement 
check box in the grey info box. You can set the angle of the 
measurement guideline by selecting it and either grabbing it 
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close to the selection handle or setting the angle numerically 
in the info box.

	

Similar to rulers, the measurement lines will display the 
distance between their intersections with outlines. Contrary 
to rulers, they do so as long as guidelines are shown, no 
matter which tool is active.

	

1.7.4	 Measurement Line
Activate measurement mode by choosing Show Measurement 
Line from the View menu (Ctrl-Opt-Cmd-M). The 
measurement line will display the sidebearings at a given 
height, ignoring the shape of the glyph at other positions. 
You can alter its height by Ctrl-Opt-Cmd-clicking or Ctrl-Opt-
Cmd-dragging.
	 Thin grey lines indicate the widths of the glyphs. The 
numbers displayed indicate the distance between the left or 
right sidebearing to where the measurement line first crosses 
the glyph outline. Negative kernings will be displayed light 
blue, positive kernings yellow.
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1.8	 ANNOTATING
The Annotation tool     (shortcut A) allows you to add simple 
notes and correction marks to your drawings. Once you 
activate the tool, the grey info box (View > Show Info) will 
turn into a little palette holding a range of annotation tools.

	

1.8.1	 Annotation cursor
The first tool on the Annotation palette is a simple edit tool 
for annotation marks. It allows you to activate, move and 
resize existing annotations. Once an annotation mark is 
activated, you can delete it by pressing the Delete key.

1.8.2	 Annotation text
The second tool from the left is a simple text tool. Activate 
it by clicking on the T button and then click anywhere on 
the canvas to add a text box. Double click on the text and 
start typing. When you’re finished, just activate the next tool 
you want to work with. You do not need to acknowledge the 
text entry.

	

The handle on the right controls the width of the text box. 
The height of the box always automatically adjusts to the 
length of the entered text.

1.8.3	 Annotation arrow
The third tool on the Annotation palette allows you to put red 
arrows on the canvas. The handle on the arrow stem controls 
the rotation of the arrow.
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1.8.4	 Annotation circle
The fourth tool puts red highlighting circles on the canvas. 
The handle at the bottom of the circle controls the diameter.

	

1.8.5	 Plus and Minus annotations
Many designers use plus and minus signs to indicate that a 
counter, a bowl or a stem needs to be thickened or thinned, 
respectively. Click on the plus or minus button and then on 
the canvas to add the symbols to the editing area.

	  

1.9	 PREVIEWING AND TESTING

1.9.1	 Previewing Masters
The edit view already is a preview of the master(s). It always 
previews the anti-aliased outlines and the kerning of the 
currently selected font master.

1.9.2	 Previewing OpenType Features
You can apply features for previewing through the menu 
at the bottom left. You may need to recompile the features 
before they are available in the pop-up list. Glyphs can only 
show a preview of substitution features. Positioning features 
are not supported.

1.9.3	 Previewing Interpolated Instances
Click on the Preview button next to the Features pop-up. The 
window content will be sectioned vertically, the Edit view 
at the top, the Preview at the bottom. Pick an instance from 
the instances pop-up next to the Preview button to see a live 
interpolation of the respective instance in the Preview area. 
Drag the separator line to adjust the size of the Preview line. 
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You can double click a letter in the Preview to make the Edit 
view center on it. Custom parameters are ignored.

1.9.4	 Previewing in InDesign
For a complete preview including things like positioning 
features and menu ordering, just pick File > Export and choose 
the Fonts folder inside the InDesign application folder as 
Export Destination. The font becomes immediately available 
in InDesign. Any previously saved instance of the font in this 
folder will be overwritten.

	

1.10	 EXCHANGING OUTLINES WITH ILLUSTRATOR

1.10.1	 Preparation
Find the right scale for the drawing in Illustrator. One point in 
Illustrator corresponds to one unit in Glyphs. An element that 
is 1000 pt high will end up at a height of 1000 units in Glyphs.
	 To get the right scale, first draw a rectangle with the height 
of the capital letters in Glyphs, copy and paste it into an 
Illustrator artboard and scale the drawings to fit the size of 
the box.
	 Alternatively, you can start in Illustrator and set the 
artboard to a height of 1000 pt. Both ascender and descender 
should fit inside these 1000 points.

1.10.2	 Set the Page Origin
If you set the page origin to the intersection of base line and 
LSB, the paths will have the right position.
	 In Illustrator up to Version CS4, set the origin of the page 
by dragging the cross in the top left corner between the 
rulers. In Illustrator CS5 or later, set the origin of the page in 
the Artboard Options.
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1.10.3	 Copy the Paths
Copy and paste the outlines. A dialog may appear, preventing 
you from pasting something far outside the bounds of 
the letter. It will move the path next to the origin, i.e. the 
intersection of base line and left sidebearing.
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2	 Palette
2.1	 PALETTE WINDOW

You can invoke the floating Palette window from the Window 
menu, or hit the shortcut, Cmd-Opt-Shift-P. The Palette has 
four sections. You can collapse or expand them by clicking 
on their title or the triangle next to it. If you butt the window 
against the left or right edge of your screen, the window 
zoom (click the green zoom button or choose Window > Zoom) 
will save space for the Palette.
	 Most Palette transformations work in both the Font 
and the Edit View. In the Edit View, they work on paths, a 
complete glyph, or even multiple glyphs.

2.2	 DIMENSIONS
The entries in the Dimensions section have no effect on any 
font parameters. They serve as a cheat sheet for your design 
process. You can enter values for a couple of crucial measures 
in your current layer.

	

2.3	 FIT CURVE
The Fit Curve panel helps creating curves with matching 
curvatures. In most instances, the collapsed (i.e. single line) 
view is enough. Select percentages by setting the left field 
to the minimum value and the right field to the maximum 
value. The buttons in between interpolate between the two 
values. Alternatively, you can press Ctrl-Opt-1 through 8.
	 The numbers describe the percentage length of the handle. 
The distance from the curve point to the intersection of the 
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handles equals 100 percent. 57 percent give you an elliptic 
curvature.
	 For finer tuning, click the little triangle to expand the Fit 
Curve panel into two dimensions. In that case, the first handle 
on each curve segment is controlled by the x axis, while the 
second one is controlled by the y axis.

	

Click one of the little buttons to alter the curvature of the 
selected curve segments. Click the same button to adjust 
other curve segments (e.g. in other letters of the same font) 
accordingly. This way, you can achieve matching curvatures 
in different curves.
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2.4	 LAYERS
Glyphs differentiates between two sorts of layers: font 
masters and regular layers.

	

Font masters are needed for interpolating instances. All 
glyphs in a font will always carry all font masters set in 
File > Font Info > Masters. In the Layers section of the Palette, 
master layers are displayed above a separator line.
	 Regular layers are displayed below the separator. They 
are stored on a per-glyph basis. You can have any number 
of layers in a glyph. Use them for keeping variations of the 
respective glyph.

2.4.1	 Working with Layers
Font masters cannot be edited through the Palette. They are 
controlled via the Font Info window.
	 Select an available master from above the separator and 
click the Copy button to create a new layer. A copy of the 
master will appear below the separator line, carrying the 
name of the master and the creation date. Double click the 
layer name to edit it.
	 To delete a layer, select it and click the minus button 
below. To exchange it with the glyph layer that is used as an 
interpolation master, click the gear button and select Use as 
Master from the menu that pops up.
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2.4.2	 Switching Glyph Shapes
In a Multiple Master font with a weight axis and no other 
axes, you can let Glyphs exchange layers with masters 
automatically for a range of weights. For this to happen, 
create layer copies of all masters. Set each layer name to the 
name of the corresponding master, followed by a space and 
a number in brackets, e.g. ‘Light [70]’ and ‘Regular [70]’. For 
instances with weight values above the bracketed number, 
Glyphs will use these layers as masters.
	 A common usage example is the vertical bar that crosses 
down through the dollar sign. In bolder variations of the 
glyph, most designers choose to split it in two and reduce it 
to whatever extends below and above the s-shaped part of 
the sign. Keep the light variations as masters and put the bold 
variants into the bracketed layers.

	

This ‘bracket trick’ only works for simple set-ups. If you want 
to exchange glyph shapes in more complex set-ups, you can 
use separate glyphs and rename them at export with custom 
parameters in the respective instances. See the Font Info 
section for more details.

2.5	 TRANSFORMATIONS
The bottom section of the palette is reserved for basic path 
tranformations. First, you need to select a transformation 
origin. This can either be Grid point calculated relatively to 
the selected paths, a manually set Reference Point, or one of 
the Metrics taken from the entries in the Masters section of 
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the Font Info, such as baseline, (half or full) x-height and (half 
or full) cap height. 

	

Once you have set the transformation origin, you can, from 
top to bottom:
	 • �mirror horizontally or vertically
	 • �scale by percentage values, the lock will keep proportions
	 • �rotate counterclockwise or clockwise by degrees
	 • slant left or right by degrees
	 • �align the selected paths to each other
The align buttons only work on complete paths, no matter 
if they are partially or fully selected. If you want to align 
individual points or segments, you need to use the grey Info 
panel and either set the width (W) or the height (H) value 
to zero.
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3	 Filters
3.1	 FILTERS MENU

Glyphs has an expandable plug-in interface. The plug-ins can 
contain filters, tools, panels and file formats. You can apply 
filters to the active layer in the edit view, or to any number 
of selected layers (with the text tool), or in the font view. The 
following filters come with Glyphs.

3.2	 HATCH OUTLINE
Creates hatched letters. Distance, width and angle of 
the hatch-lines can be chosen. Glyphs always uses the 
background path as source. If there is no path, Glyphs will 
put a copy of the current path into the background. Alter the 
appearance of the hatching by changing the background path 
and applying the filter once again.

3.3	 OFFSET CURVE
Changes the thickness of stems horizontally and / or 
vertically. Open paths will be expanded into closed outlines.

3.4	 REMOVE OVERLAP
Removes overlaps of selected paths. If no paths are selected, 
the filter will be applied to all paths of the selected letter(s).

3.5	 ROUND CORNERS
Apply this in order to round all selected corners. To only 
round the outside corners, simply select nothing. Use the 
Visual Corrections option to adjust the radius of different 
corner angles and create a more consistent appearance. 

3.6	 TRANSFORMATIONS

3.6.1	 Transform
Use Transform to horizontally and vertically move, scale 
and tilt glyphs. Fix the origin when scaling and tilting. Tilt 
without optical correction by choosing Slant, or with optical 
correction with the Cursify option. Cursify requires correctly 
set vertical and horizontal stems (see also Font Info > Master).
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3.6.2	 Background
Use Background to interpolate between front and background 
paths. The paths need to be compatible.

3.6.3	 Metrics
Use Metrics to set the width or the sidebearings of a letter. 
With the Relative option, the values will be added or 
subtracted.
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4	 Font View
4.1	 VIEWING GLYPHS

By default, a new font contains uppercase A-Z, lowercase 
a-z and space. You can choose to view different excerpts of 
your glyphs by selecting categories, languages or filters from 
the left. Alternatively, you can enter a search term in the 
search field at the bottom right of the window (Cmd-F). By 
clicking on the magnifying lens, you can choose to search for 
unicodes instead of glyph names.

	

With the slider next to it, you can control the zoom level of 
the displayed glyphs.
	 The three numbers to the left indicate (from left to right)
how many glyphs are selected, how many are currently 
displayed, and the total number of glyphs in the font file.

4.2	 ADDING GLYPHS
There are several ways to add new glyphs:
• �Font > New Glyph (Cmd-Opt-Shift-N) adds an empty glyph 

called ‘newGlyph’.
• �Font > Duplicate (Cmd-D) duplicates the currently selected 

glyph(s).
• �Font > Add Glyphs (Cmd-Shift-G) opens a window where you 

can insert a list of glyph names. As far as information about 
components is available, the glyphs will be built from them.

	   

• �Some entries in the sidebar of the font view have a number 
badge. Right-click or Ctrl-click it to get a list of all glyphs 
missing in this category. Select one or more glyph names, 

For the complete list of 
recognized glyph names, 
choose Glyphs Info from 

the Window menu.

http://sourceforge.net/adobe/aglfn/wiki/AGL%20Specification/
http://sourceforge.net/adobe/aglfn/wiki/AGL%20Specification/
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or hit Cmd-A to select all of them, and click Generate to add 
them to your font.

4.3	 GLYPH PROPERTIES
Select some glyphs and click on the second button  at the 
bottom left of the window, and the Glyph Properties will 
be displayed. Some of the properties can also be accessed 
through the context menu.

4.3.1	 Name
The glyph name can be accessed and changed only if exactly 
one glyph is selected.

4.3.2	 Width and Sidebearings
The widths as well as the left and right sidebearings can be 
accessed and changed for any number of selected glyphs at 
once. Changing the width only affects the right sidebearing.

4.3.3	 Kerning Groups
You can set kerning groups for a range of glyphs, see the 
section on Spacing and Kerning for further details.

4.3.4	 Exports
The glyph will appear in the exported font only if this radio 
box is checked. Use this for keeping glyph variations for 
later use.
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4.3.5	 Color Label
For easier sorting and filtering, or simply for keeping 
oversight, you can mark glyphs with one of ten predefined 
colors. The colors have no effect on the exported font.

4.3.6	 Unicode
The Unicode is determined by the glyph name, which means 
that you cannot set the value directly. Thus, the displayed 
Unicode is read-only.

4.3.7	 Note
In list view, you can display even more properties as 
columns. Just right click on the columns headers and tick off 
the columns you want to see. You can use them as sort key. 
Switch between ascending and descending sorting by clicking 
on the column title.

4.3.8	 Read-Only Properties in List View
The following properties can only be accessed in List View, 
they are read-only and only useful for sorting glyphs:
	 • �Unique Glyph ID (corresponds to the glyph order in the 

font; you can only change this by setting the Custom 
Parameter ‘glyphorder’)

	 • �Character (i.e. the Unicode character as represented by the 
OS X system font Lucida Grande)

	 • Script (e.g. ‘Latin’, ‘Greek’, ‘Cyrillic’)
	 • Category (e.g. ‘Letter’, ‘Number’)
	 • Subcategory (e.g. ‘Uppercase’)
	 • �Last Changed (i.e. date and time of the last manipulation 

of the glyph)



� Glyphs Handbook, June 2012    31

4.4	 FILTERING AND SORTING

	

Filters can help you get an overview of the glyphs in the font. 
There are predefined letter, type and language categories. In 
addition, you can define your own filters, e.g. query filters, 
similar to smart playlists in iTunes, or simple list filters. You 
can add a Filter with the button in the lower left corner. Set 
up the query with these properties: 
	 • glyph name
	 • script (e.g. Latin or Arabic)
	 • count of paths (in the first master)
	 • compatibility of masters
	 • whether the glyph exports or not
	 • whether the first master has components or not
	 • color label
Once you have set up a couple of filters, you can apply more 
than one filter by holding down the Cmd key and clicking the 
Filter names.

4.5	 NAMES AND UNICODE

4.5.1	 Naming and Renaming Glyphs
The glyph name appears below the glyph in grid view, or in 
a separate column in list view. You can edit a glyph name 
by clicking once into the name. Glyphs will automatically 
convert entries like ‘ä’ or ‘uni00E4’ to its own naming 
convention (which is, for the Latin part, loosely based on the 
Adobe Glyph List Specification), i.e. ‘adieresis’ in this case. 
A dialog will appear if you try to use illegal characters like 
space in a glyph name.

For more information about the 
Adobe Glyph List, see  

http://sourceforge.net/
adobe/aglfn/home/Home/

http://partners.adobe.com/public/developer/opentype/index_name.html
http://sourceforge.net/adobe/aglfn/home/Home/
http://sourceforge.net/adobe/aglfn/home/Home/
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	 For a list of built-in glyph names, choose Glyph Info 
from the Window menu. Glyphs will automatically assign 
Unicodes and can even build OpenType features based on the 
glyph names.
	 If you need variations of glyphs, extend your glyph names 
with dot suffixes, like ‘n.sc’ for a small cap n, or ‘five.sups’ for 
a superscript five. See the appendix of this manual for a list of 
recognized suffixes.
	 You can search and replace in the names of selected glyphs 
via Edit > Find > Search and Replace (Cmd-Shift-F). If you leave 
the Find field blank, then whatever is entered in the Replace 
field will be appended to the names of all selected glyphs.

You can copy the names of selected glyphs through the 
context menu. The names will be copied as a slash-delimited 
line of plain text, e.g. the names of a, ä, b and c will be stored 
in the clipboard as: ‘/a/adieresis/b/c’.

4.5.2	 Readable or Nice Names
Glyphs contains a glyph info database that holds information 
about, names, Unicode, components, anchors and the like.
	 Not all glyphs that are defined in the Unicode database 
have official glyph names. For these, one would typically 
use names like ‘uni042F’ or ‘afii10049’, which are hard to 
memorize. Instead, Glyphs uses the Unicode description and 
appends a script suffix, e.g. ‘CYRILLIC CAPITAL LETTER A’ 
becomes ‘A-cy’.
	 To name ligatures, the names of the components need to be 
joined with an underscore. The script suffix will be appended 
only once (e.g. ‘lam_alef-ar’). Variation suffixes are only 
added once as well. These suffixes define the role of the whole 
ligature. For instance, a ligature formed of ‘lam-ar.init’ and 
‘alef-ar.medi’ is called ‘lam_alef-ar.init’.
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	 If you set the glyph name, all other values will be set 
automatically. If necessary, even the name will be changed. 
Glyphs accepts three different types of input values:
	 • the actual name, e.g. ‘Ia-cy’
	 • �the Unicode value in hex form with a ‘uni’ prefix, e.g. 

‘uni042F’
	 • �the Unicode character as typed from the keyboard, e.g. ‘Я’
This automatism can be deactivated on a font basis: Go to 
File > Font Info > Other Settings and check the ‘Don’t use 
nice names’ option. In this case, however, other automatic 
functions, like components and feature generation, will not 
work either.
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5	 Font Info
5.1	 FONT 

5.1.1	 Family Name
The name of the font family as it will appear in a font menu. 
Fonts carrying the same Family Name will be grouped in 
the same Style submenu. You can use a space in the font 
name, but non-ASCII characters may prevent the font 
from exporting.

5.1.2	 Units per Em
Number of units per em square (UPM). 1000 is the default. 
Increasing the UPM value improves the representation of 
subtle details. The OpenType allows values up to 16,000 but 
values greater than 5000 can lead to problems in InDesign 
and Illustrator. If you need higher precision, it might be 
better to deactivate the grid by setting it to zero (see Font 
Info > Other settings > Grid Spacing).
	 Click on the double arrow next to the text field to scale the 
entire font.

5.1.3	 Designer and Designer URL
Here, you can enter your name and a URL (including the 
protocol, i.e. http:// or ftp://), for example:
	 • Designer: Jessica Doe
	 • Designer URL: http://www.jessicadoefonts.com/
The entries correspond to OpenType Name IDs 9 and 12. You 
can check if the URL was entered correctly by clicking on the 
circled arrow next to it.

5.1.4	 Manufacturer and Manufacturer URL
Here, you can enter name and URL (including the protocol, i.e. 
http:// or ftp://) of your font vendor, for example:
	 • Manufacturer: Superfontstore
	 • Manufacturer URL: http://www.superfontstore.com/
The entries correspond to OpenType Name IDs 8 and 11. You 
can check if the URL was entered correctly by clicking on the 
circled arrow next to it.
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5.1.5	 Copyright
A simple copyright notice. Click the circled arrow next to it to 
have Glyphs fill it in automatically. This will be recorded as 
Name ID 0.

5.1.6	 Version
Glyphs derives the Version string (Name ID 5) from the 
Version entry.

5.1.7	 Date
The creation date of the font. Will set the Creation and 
Modification dates in the OpenType head table.

5.1.8	 Custom Parameters
Use entries to specify more parameters. To add a parameter, 
click on the green plus symbol, select or type a property, and 
enter a value. You can use custom parameters to override 
values set automatically by Glyphs. With most of them, 
you can directly set values in the various OpenType tables. 
Glyphs considers a range of possible properties, for instance:
	 • openTypeOS2WeightClass
	 • openTypeOS2Panose
	 • openTypeOS2UnicodeRanges
	 • openTypeOS2VendorID
	 • openTypeNameDescription (Name ID 10)
	 • openTypeNameLicense (Name ID 13)
	 • openTypeNameLicenseURL (Name ID 14)
	 • openTypeNameSampleText (Name ID 19)
	 • openTypeNameWWSFamilyName (Name ID 21)
	 • openTypeNameWWSSubfamilyName (Name ID 22)
	 • postscriptBlueFuzz
	 • postscriptBlueScale
	 • postscriptBlueShift
	 • postscriptBlueValues
	 • trademark
	 etc.
These names are adopted from the UFO specifications. For 
details and a complete list, see http://unifiedfontobject.org/
versions/ufo3/fontinfo.html.

http://unifiedfontobject.org/versions/ufo3/fontinfo.html
http://unifiedfontobject.org/versions/ufo3/fontinfo.html
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5.2	 MASTERS
While information about the designed masters (the input) is 
set under ‘Masters’, the ‘Instances’ tab contains information 
about each instance that will be generated when fonts are 
exported (the output). Use the plus and minus buttons to add 
masters, and the ‘Add’ button to add any open single-master 
font as a master to the current font. You can add the font to 
itself to have two identical masters to start from.
	 Standard stems and alignment zones are necessary 
to optimize the font’s rendering on screen, where these 
characteristics may be represented by only a few pixels. Small 
deviations in the drawing can – after rounding to the pixel 
grid – result in considerable differences. Stems should have 
a uniform thickness. Alignment zones help create an even 
vertical alignment by overshoot suppression. The values 
entered here are crucial for the autohinting process when the 
font is being exported.
	 All values will be interpolated if entered in the same order 
throughout all masters. You can edit several masters at once 
after you Shift-click or Cmd-click the master names in the list 
on the left.

5.2.1	 Proportions: Width and Weight
The values in these two pop-ups affect only the toolbar 
icons. The values for the actual interpolation are set under 
‘Instances’. For more information about this, see the Multiple 
Master chapter.

5.2.2	 Metrics
The vertical metrics have an impact on the line height, 
and serve as a guideline in the editing window. Glyphs will 
calculate the vertical metrics in the OS/2 and hhea tables 
from these values.
	 Also, Glyphs is able to find alignment zones (see below) 
automatically if you first enter correct vertical metrics: 
ascender, cap height, x-height, descender, perhaps also a 
smallCapHeight in the Custom Parameters.
	 When determining these values, ignore the overshoot. So, 
for instance, if you have the choice between various values 
for the x-height, say 490, 496 and 502, you want the one 
closest to your baseline, i.e. 490.
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5.2.3	 Stems
If you enter good values for your standard stems, the 
autohinter will find those stems in your letters and put a 
hint on them. Try to find values as representative as possible, 
separated by a comma.
	 For vertical stems, consider the widths of your lowercase 
and uppercase stems and bowls. It’s a good idea to measure 
the stem width of a lowercase i and an uppercase I, and 
the distance between the extremum points in the bowls of 
lowercase c and uppercase C. For horizontal stems, consider 
the bars of t and E, the upper bowls of o and O, and the 
thickness your serifs if you have any.
	 Usually, not more than two stem values (for either 
horizontal or vertical stems) are necessary. If a few 
potential values are very close to each other, pick the most 
representative one, e.g. if you get measurements of 20, 21, 23, 
43, 44 and 45 for your horizontal parts in your glyphs, then 
just enter 21 and 44 as your horizontal stems.

5.2.4	 Alignment Zones
An alignment zone must encompass anything that should 
later be aligned at a low resolution. For instance, the upper 
edge of the crossbar of t, the upper edge of x and the highest 
extremum of o, they should be inside the alignment zone for 
the x-height. However, the size of an alignment zone must 
not exceed 25 (or –25 for bottom zones), and there must be at 
least one unit between any two alignment zones.
	 After you have set the Metrics properly, you can click the 
grey circle to let Glyphs find the alignment zones for you. It is 
a good idea to double check if your most important glyphs do 
end inside the alignment zones.

5.2.5	 User Parameters
Click on the green Plus button to add custom parameters for 
the masters. Numeral values are interpolated if defined for 
all masters.

5.3	 INSTANCES
Use the plus and minus buttons to add and remove instances. 
You can edit several instances at once after you Shift-click or 
Cmd-click the instance names in the list on the left.

For an in-depth discussion of 
hinting, see: 

 http://typophile.com/files/
hinting.pdf, 

http://partners.adobe.
com/public/developer/en/

font/T1_SPEC.PDF and 

http://vimeo.com/38364880.

http://typophile.com/files/hinting.pdf
http://typophile.com/files/hinting.pdf
http://partners.adobe.com/public/developer/en/font/T1_SPEC.PDF
http://partners.adobe.com/public/developer/en/font/T1_SPEC.PDF
http://partners.adobe.com/public/developer/en/font/T1_SPEC.PDF
http://vimeo.com/38364880
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5.3.1	 Style Name
This is the style name as it will appear in InDesign’s font 
menu. You can use a space in the style name, but non-ASCII 
characters may prevent the font from exporting.

5.3.2	 Weight and Width
These settings affect the order of fonts in the font menu. 
Sorting occurs first by width, then by weight, e.g.:
	 • Condensed Light
	 • Condensed Regular
	 • Condensed Bold
	 • Light
	 • Regular
	 • Bold
	 • Extended Light
	 • Extended Regular
	 • Extended Bold

5.3.3	 Style Linking
Microsoft Windows applications support only the basic four 
styles per font family, i.e. Regular, Italic, Bold and Bold Italic. 
They are accessed via the ‘B’ and ‘I’ buttons in the toolbar. Mac 
applications can switch to linked Bold and Italic styles via the 
Cmd-B and Cmd-I shortcuts. Adobe InDesign does the same 
via Cmd-Shift-B and Cmd-Shift-I. If a font family is not style-
linked at all, then each style appears individually in the font 
menu. In that case, clicking the ‘B’ or ‘I’ buttons may create a 
synthetic Bold or Italic.
	 Based on these conditions, the following strategy is 
recommended:
	 • �Italic styles should always be linked to their upright 

counterparts. They must share the same family name.
	 • �The Bold style should always be linked to the Regular.
	 • �Larger font families require a carefully devised linking 

strategy.
Linking the SemiBold to the Light is sometimes practiced. If 
you choose to do so, only the Light will appear in the font 
menu and many users are unaware that they can access the 
SemiBold style by selecting Light and then choosing ‘bold’ 
However, if you want to link SemiBold to Light, enter the 
name of your Light style in the ‘Linked style’ text field of your 
SemiBold instance settings and check ‘is Bold’.
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	 Some designers prefer a different strategy, according to 
which only the Bold, Italic and Bold Italic are linked to the 
Regular. For the rest, only the italics are linked to the uprights 
with the same name, e.g. Medium Italic is the Italic of 
Medium. No Bold setting is used furthermore.

5.3.4	 Interpolation
The Weight and Width settings apply to the design space 
spanned between the Masters. For further details, see the 
chapter on Multiple Masters.

5.3.5	 Custom Parameters
The following values are being considered during export.
	 • TypoAscender
	 • TypoDescender
	 • TypoLineGap
	 • winAscent
	 • winDescent
	 • �openTypeNameLicense (is given precedence over the 

same option in Font Info)
	 • �openTypeNameLicenseURL (is given precedence over the 

same option in Font Info)
	 • �openTypeOS2WeightClass (overwrites all weight settings)
	 • �openTypeOS2WidthClass (overwrites all width settings)
There are some special properties:
	 • �Scale to UPM: scales the font immediately after 

interpolation to avoid rounding errors.
	 • �Filter: you can apply a filter after the glyphs are 

interpolated and the overlap is removed. So far, only 
the ‘Round Corners’ filter is supported. Add ‘Filter’ as a 
property in the left column and ‘GyphsFilterRoundCorner; 
<Radius>; <Visual Correction>’ as its value in the right 
column, e.g. ‘GlyphsFilterRoundCorner; 30; 1’.

	 • �Remove Glyphs: takes a comma-separated list of glyph 
names. The glyphs will not appear in the final font.

	 • �Rename Glyphs: takes a comma-separated list of 
‘oldglyphname=newglyphname’ pairs. This is useful if 
you use glyph alternatives in specific instances.

	 • �InterpolationWeightY: you can specify a different Weight 
value for interpolating in Y direction.

Pro User Tip: In complex 
Multiple Master set-ups, the 

Bracket trick described in the 
Layers chapter does not work. 

In that case, create copies of 
the glyphs (e.g. dollar and cent) 

and add a ‘.bold’ suffix to their 
name (dollar.bold, cent.bold). In 

the bolder instances, add two 
custom parameters. First, use 

‘Remove Glyphs’ for the original 
glyphs (e.g. ‘dollar, cent’). Then 

add ‘Rename Glyphs’ to put 
the .bold glyphs in their place 

(e.g. ‘dollar.bold=dollar, cent.
bold=cent’). To be complete, you 

can use a custom parameter 
in your lighter weights to 

remove the .bold glyphs there.
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5.4	 FEATURES
Glyphs automatically generates most of the common features, 
click the circled arrow in the corner to initiate that. The 
feature generator is based on certain name conventions and 
suffixes. E.g. all letters with names ending in ‘.sc’ are being 
located in the small caps feature. Letters described with 
more than one letter name joined by underscores are being 
recognized as ligatures. Find a complete list of the suffixes in 
the appendix.
	 To write features manually, uncheck the ‘Automatic’ 
checkbox or create a new feature by clicking the plus button 
at the bottom left. Edit the name of the feature (or class) 
directly in the list. Glyphs uses Adobe FDK syntax. Find 
details at http://www.adobe.com/devnet/opentype/afdko/
topic_feature_file_syntax.html.
	 Put all information that needs to stand outside a feature 
in the prefix. Glyphs will put language systems here. This is a 
good place for mark classes and OpenType tables like GDEF.
	 The bottom right area is for notes. In Stylistic Set features 
(ss01 through ss20), you can use it to set the name of the 
Set. Type ‘Name:’, followed by the intended description. 
Alternatively, you can enter the complete featureNames 
lookup as described in the Adobe FDK syntax.

5.5	 OTHER SETTINGS

5.5.1	 Grid Spacing
The grid width defines how coordinates get rounded. Standard 
is the value 1. When set to zero, no rounding will happen. 
This is useful if you want to keep very fine details, e.g. after 
applying the Hatch Outlines filter or in detailed dingbat fonts. 
Higher values are helpful when creating a pixel font.
	 All tools and all modifications will consequently snap 
to the grid. You can force all point coordinates of selected 
glyphs into the grid by choosing Round Coordinates from the 
Layers menu.

5.5.2	 Don’t Use Nice Names
This option prevents the automatic replacement of glyph 
names. This might be of importance where special workflow 
requirements apply. The option is set in all fonts imported 
from OTF files and UFOs that are opened with Glyphs for the 

http://www.adobe.com/devnet/opentype/afdko/topic_feature_file_syntax.html
http://www.adobe.com/devnet/opentype/afdko/topic_feature_file_syntax.html
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first time. Deactivating this option does not immediately 
activate the automatic replacement of names. To activate the 
automatic naming, pick Font > Update Glyph Info. Attention: 
this may also invalidate the feature code.
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6	 Spacing and Kerning
6.1	 SPACING

Spacing is the process of adjusting the sidebearings to get an 
even rhythm of the text. There are no fixed rules for adjusting 
the white space. However, the same shapes should have the 
same sidebearing, e.g. the D has the same LSB as the H, but its 
RSB is more like the O.

6.1.1	 Spacing Shortcuts
There are keyboard shortcuts to change the spacing of a letter. 
Hold down the Ctrl key and use the left and right Arrow keys 
to change the LSB. Cmd and arrow keys changes the RSB. Add 
the Shift key to manipulate in increments of 10 units.

6.1.2	 Linked Metrics
Linked metrics work in a very similar way as kerning 
classes: Put in the name of the glyph you want to link to 
in the sidebearing field and it will automatically adopt 
the respective side bearing. Note that this is not updated 
automatically. You need to select the glyphs that need 
updates and select Layer > Update Metrics. Or update by 
clicking in one of the metric fields in the info box and then 
clicking somewhere else.
	 You can even enter simple calculations into the sidebearing 
field. Calculations need to start with an equals sign (‘=’). For 
instance, ‘=n+10’ will take the same sidebearing of n and 
add 10 units, ‘=n-10’ subtracts 10 units, ‘=g/2’ yields half the 
sidebearing of g, and ‘=v*2’ twice the sidebearing of v. 
	 Use the pipe character (‘|’, Shift-backslash on a U.S. 
keyboard, Opt-7 on a German keyboard) to reference the 
opposite sidebearing. E.g., in the RSB of e, you can enter ‘=|a’ 
to use the LSB of a as the RSB of e.

6.2	 KERNING
Most glyphs fit well next to each other but some pairs need 
specific adjustments, e.g. T in combination with o. This is 
where kerning comes into play.

6.2.1	 Ways to Kern
To define these kerning pairs, switch to the Text Tool, type 
both glyphs in the Edit View and place the cursor between 

Easy to memorize: the Ctrl 
key is located on the left, 
the Cmd key on the right. 

The keys are associated 
with the left and right 

sidebearing, respectively.
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them. The bottom left field (labeled ‘K:’) in the info box will 
show the kerning value for this combination. Just set a value 
there.
	 Or use the keyboard shortcuts for much greater 
convenience. Similar to the metrics keys, Ctrl-Opt-(Shift-)
Arrow keys changes the kerning towards the letter on the left 
side of the current letter, while Cmd-Opt-(Shift-)Arrow keys 
change the kerning with the letter following on the right.

6.2.2	 Kerning Groups
Many glyphs look similar and need the same kerning values. 
Kerning groups capture these similarities and help you reduce 
the number of pairs that need to be set manually. Kerning 
then applies not to glyphs, but to groups of glyphs, in the 
sense of kerning all glyphs that look like an A or like a T etc.
	 In Glyphs, kerning classes are not edited as glyph lists. 
Instead, the class membership is defined as a glyph property. 
For example, put O in the left kerning group field for all 
glyphs that look like an O on the left (like C, Ccedilla, G, 
Odieresis and O itself ). Add a value to each glyph, even if it 
remains the only glyph in its group. Switch to the list mode 
of the Font View for a better overview.

	

You can introduce exceptions to group kerning by opening the 
kerning lock in the grey info box. Thus you can have different 
kerning pairs for ‘To’ and ‘Tö’. Vice versa, keep these locks 
closed if you do not want any exceptions.

6.3	 SAMPLE TEXTS
The predefined sample texts cover the most important 
combinations in Latin fonts. Select Font > Select Sample Text… 
(Cmd-Opt-F) and choose a line. Use the Arrow keys to move 
the cursor and the Enter key to close the dialog. You can 
define your own texts in the application preferences.
	 If you want to space a lot of letters, you can use dynamic 
placeholders in the sample text. Placeholders always show 
the current glyph. This can come in handy when you step 
through your glyphs and want to see how each of them looks 

Tip: quickly advance to the 
next glyph by typing Page 

Up and Page Down (Fn and 
left and right arrow keys 
on a MacBook keyboard).
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in different situations or as a double letter. Choose Edit > Add 
Placeholder (Cmd-Opt-Shift-P) to insert a placeholder.
	 You can color mark the kerning between glyphs in a 
sample text if you display the measurement line. For more 
details on this, refer to the Edit View chapter.
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7	 Multiple Master
7.1	 OVERVIEW

With Multiple Masters you only draw the extreme styles of a 
font family and then interpolate the styles in between. 
It is not advisable to store all single styles of one family 
in one file, especially not upright and italic styles. You can 
interpolate between up to five masters. Glyphs supports the 
following arrangements:

	

Light BlackSemibold

SemiboldLight Black

Light Condensed Bold Condensed

Light Black

Light Condensed Bold Condensed

Light BoldBold

Condensed

Light

The relation between the masters is defined by their 
coordinates, i.e. their width and weight properties. In 
addition, you can define other dimensions. The masters span 
a design space in which the instances can be placed.
	 The nodes of the outlines are not automatically linked 
between the masters. You can insert nodes in one master 
while all other masers stay untouched. Note that for the final 
interpolation, the masters need to be compatible, though.
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7.2	 SET-UP
Defining the coordinates of the masters sets up the design 
space. For the Weight coordinate, it is recommended to use 
the stem width of a representative letter such as the n. This 
makes it easier to define the stem widths of the instances. 
The Weight coordinate is entered in the text entry field next 
to the pop-up. 

   

Use the pop-up list to set the name of the master and the 
icon in the toolbar. This setting is not used for the style of 
the exported font; it is a rough guideline that allows for 
convenient buttons. The styles of the final fonts are defined in 
the instances.

7.3	 MERGING TWO FILES
You can merge two or more open files into one Multiple 
Master File. To do so, activate the lighter font, go to Font 
Info > Masters and click Add in the bottom left corner. Select 
the other font in the upcoming dialog and click ‘OK’. Repeat 
this for all files you want to add, then set weight and width 
for all masters. 

7.4	 FIX COMPATIBILITY
When merging masters, Glyphs does not automatically 
fix incompatible outlines. If necessary, this can be done 
manually. Letters with incompatible outlines are marked 
with a red triangle in the font view and a red stripe in edit 
view. During editing, it is possible to work with incompatible 
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paths but for interpolation, they need to be compatible. 
Specifically, this means that the order of the paths as well 
as number and structure of nodes must correspond with 
each other.
	 View > Show Master Compatibility (Ctrl-Opt-Cmd-N) 
activates a visualization of the masters’ congruency. The 
red lines connect the corresponding nodes in all masters. If 
the picture looks as wild as in the first sample picture, then 
something is fundamentally wrong. The three slightly bigger 
red numbers indicate the paths’ starting points and the path 
order. Straight blue lines connect the starting points of all 
masters. When comparing outlines, you always start at the 
start node of the paths and follow them in the direction that 
is indicated by the small triangle at the first node.
	 The colored segments indicate the compatibility of the 
segments. Red means that there is a line in one master and 
a curve in the other. These masters will not interpolate at 
all. Yellow means that the paths are of the same type but 
have a different angle. They will interpolate but may yield 
an unexpected result: differences in angles can turn smooth 
connections into so-called ‘kinks’, i.e. corners. Green segments 
are fully compatible.
	 Example:

In the foreground you see colored light master and in 
background the bold master’s paths, displayed in light grey. 
The foreground has an overlap, while the background has 
none. Choose Filter > Remove Overlap to get the second 
picture.

Tip: Quickly switch 
between masters with 

Cmd-1, Cmd-2 etc.
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	 The outlines seem to fit now. i.e. the y have the same 
number of nodes. The blue lines connecting the starting 
points in all masters are running across the letter though. 
The starting nodes have to be at the same position. Either 
correct that manually by right clicking the node and choosing 
‘Make node first’, or use the command Layer > Correct Path 
Direction (Cmd-Shift-R) on all masters.
	 In the third image, the start points are at the same position 
in both masters and all outlines are green.

7.5	 LAYERS PANEL
The Layers Panel shows all layers of the selected glyph. The 
master layers are shown on top. You can copy them to save 
a working state. Select the layer in the list and click the 
Copy button. When clicking an entry in the list, the selected 
layer is activated in the current glyph only. This is helpful to 
simultaneously see different layers of one glyph.

	

To change view between master layers, use the tool bar 
buttons. Also there is the shortcut Cmd-1, Cmd-2 etc., i.e. Cmd 
and the number of the respective master.
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8	 Error Handling
8.1	 GLYPH NAMES

The most common source of problems are illegal glyph 
names. Make sure all your glyph names:
	 • �only contain letters A-Z, a-z, numerals 0-9, 

underscore (‘_’), dash (‘-’) or period (‘.’)
	 • start with a letter (A-Z, a-z),
	 • �have no whitespace characters (space, tab, return etc.), 

not even at the end,
	 • contain no non-ASCII characters (like á, è, ß or ü).
Not adhering to these guidelines may yield an error message 
like ‘No File was created. The reason is unknown.’

8.2	 FONT NAMES
If your error message only entails a POSIX path to a file called 
‘FontMenuNameDB’, set between brackets (‘[/Users/<your 
username>/Library/Application Support/Glyphs/Temp/<your 
fontname>/FontMenuNameDB]’), then there probably is an 
illegal character in the font name or style name. You can use 
spaces, but as of yet, no non-ASCII characters.

8.3	 DUPLICATE UNICODES
In some fonts, two or more letters erroneously carry the 
same Unicode. If you try to import a font with double 
encodings, Glyphs will warn you. Selecting all glyphs and 
choosing Update Glyph Info from the Font menu will usually 
fix that problem.
	 The other way around, the situation where one glyph 
sports two Unicodes, is fixed silently based on the glyph 
name. The usual suspects for this are Delta and Omega. Delta 
should only be U+0394, but sometimes also has U+2206, the 
code for the mathematical increment operator (a.k.a. Laplace 
operator). Omega, which should only be encoded with 
U+03A9, sometimes also sports U+2126, the codepoint for the 
Ohm symbol.

8.4	 OPENTYPE FEATURE CODE
If all your features are auto-generated, you can usually 
fix feature code troubles by re-compiling, i.e. clicking the 
Compile button in the Feature tab of the Font Info window.
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	 Glyphs tries to pass on any FDK compilation errors in 
an error dialog. And it also tries to point you to where the 
problem occurred by reporting the name of the problematic 
feature and the line number. If it succeeds in doing so, the 
error dialog will sport a ‘Show’ button. Click on it and Glyphs 
takes you directly to the code problem.
	 The following errors may occur:
	 Contextual substitution clause must have a replacement rule or 
direct lookup reference. You probably forgot or mistyped the 
word ‘by’ in a substitution feature.
	 DFLT script tag may be used only with the dlft language tag. You 
tried using a language tag without a preceding script tag, e.g. 
somewhere before ‘language DEU;’, there needs to be a ‘script 
latn;’.
	 Glyph x not in font. You tried referencing a glyph that does 
not exist. The error message will tell you which glyph it was 
looking for in vain. You probably mistyped the name of the 
glyph, accidentally deleted the actual glyph, renamed the 
glyph, or forgot to create the glyph in the first place.
	 Target glyph class in rule doesn’t have the same number of 
elements as the replacement class. You tried substituting a class 
with a class of a different size. The error dialog will point you 
to the problematic code line. Make sure the classes are of the 
same size.
	 Syntax error. This can have several reasons:
	   • �You are using non-ASCII characters in your code or 

feature names.
	   • �You mistyped feature commands like ‘sub’, ‘pos’ or ‘by’.
	   • �You forgot a semicolon at the end of a code line. In this 

case, the error message will contain ‘missing “;” ’.
	   • �You forgot a numerical value in a positioning lookup. 

In this case, the error message will also contain 
‘missing NUM’.

8.5	 OUTLINE COMPATIBILITY
Incompatible outlines should not hinder OTF export. Affected 
glyphs are simply exported empty. If you get a ‘Some glyphs 
are not compatible and will have no outlines’ error message, 
the font will still be exported. You can find more details about 
fixing incompatible outlines in the Multiple Master chapter.
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9	 Import and Export
9.1	 FONTLAB

9.1.1	 From FontLab to Glyphs
There is a Python script available to export Glyphs files 
directly from within FontLab. You can download it from 
github.com/schriftgestalt/Glyphs-Scripts/ Look for a Script 
called ‘Glyphs Export.py’. To install, copy it to this folder: 
/Users/[your user name]/Library/Application Support/
FontLab/Studio 5/Macros/Glyphs Export.py. After restarting 
FontLab, it will become available in the macro toolbar.
	 If you have the UFO tools installed, you can also export 
the font as a UFO file and open it in Glyphs. FontLab uses a 
non-standard format for storing kerning and kerning classes. 
Glyphs detects this and converts it to its own system. This 
only works if you have a common suffix for left and right 
kerning classes, like ‘_L’ for left side and ‘_R’ for right side. You 
have to tell Glyphs about that in the preferences.

9.1.2	 From Glyphs to FontLab
Again, there is a Python script to import Glyphs files into 
FontLab. You can get it from the same Github repository 
mentioned above. This time, look for a script named ‘Glyphs 
Import.py’ and place it in your FontLab Macro folder.

9.2	 ROBOFONT AND OTHER UFO TOOLS
Glyphs can read and write UFO files. Unfortunately, .ufo files 
cannot contain more than one master. So, File > Export will 
export a Multiple Master Glyphs font as several UFO files.

http://github.com/schriftgestalt/Glyphs-Scripts/blob/master/Glyphs Export.py
http://github.com/schriftgestalt/Glyphs-Scripts/blob/master/Glyphs Export.py
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10	 Appendix
10.1	 FEATURE SUFFIXES
liga Ligature Join the glyph names of the components 

with an underscore (‘_’). The common 
ligatures with f, i and l are placed in the liga 
feature, all others go into dlig. If you want to 
force a ligature into the liga feature, you can 
add a ‘.liga’ suffix, e.g. ‘f_b.liga’.

dlig Discretionary 
Ligatures

Join the glyph names of the components 
with an underscore (‘_’), e.g. ‘f_odieresis’.

c2sc Small Capitals 
from Capitals

Add ‘.sc’ to the (lowercase) glyph name.

smcp Small Capitals Add ‘.sc’ to the (lowercase) glyph name.

sups Superscript Add ‘.sups’ or ‘superior’ to the glyph name.

subs Subscript Add ‘.subs’ to the glyph name.

sinf Scientific 
Inferiors

Add ‘.sinf’ or ‘.subs’ to the glyph name.

dnom Denominators Add ‘.dnom’ to the glyph name.

numr Numerators Add ‘.numr’ to the glyph name.

onum Oldstyle Figures Add ‘.osf’ (for proportional oldstyle figures) 
or ‘.tosf’ (for tabular oldstyle figures) to the 
glyph name.

tnum Tabular Figures Add ‘.tf ’ (for tabular figures) or ‘.tosf’ (for 
tabular oldstyle figures) to the glyph name.

pnum Proportional 
Figures

Add ‘.osf’ (for proportional oldstyle figures) 
or ‘.lf ’ (for proportional lining figures) to the 
glyph name.

lnum Lining Figures Add ‘.lf ’ (for proportional lining figures) or 
‘.tf ’ (for tabular figures) to the glyph name.

hist Historical Forms Add ‘.hist’ to the glyph name.

frac Fractions The frac feature is generated from the 
.numr, .dnom and fraction glyphs. Pre-built 
fractions are also added: onehalf, onequarter, 
threequarters, oneeighth, threeeighths, 
fiveeighths and seveneighths.

If you have separate sets 
for c2sc and smcp, you can 

use ‘.c2sc’ for uppercase 
glyph names and ‘.smcp’ for 

lowercase glyph names.
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locl Localized Forms Add ‘.loclXXX’ to the glyph name, where XXX 
represents the three letter language tag, e.g. 
‘.loclENG’ for English. There also is a built-in 
list of glyphs which are added automatically 
to the feature, e.g. idotaccent, scommaaccent 
and tcommaaccent will trigger locl 
substitutions for Turkish, Romanian and a 
range of related languages.

ssXX Stylistic Set Add ‘.ssXX’ to the glyph name, for example 
‘.ss01’ or ‘.ss12’. Add ‘Name:’ plus the feature’s 
descriptive name to the feature note at the 
bottom. This will generate the feature name 
entries for stylistic set names. Alternatively, 
you can add the whole featureNames 
definition to the note.

For a complete list of 
language tags, see: 

microsoft.com/typography/
otspec/languagetags.htm

http://www.microsoft.com/typography/otspec/languagetags.htm
http://www.microsoft.com/typography/otspec/languagetags.htm

